Update 22/03/2024 - 18h30: DDoS attacks have continued throughout the past few days. We've been actively working with our anti-DDoS provider to mitigate these attacks while limiting the impact on our customers. We will continue to monitor the situation throughout the weekend and next week until the attacks subside.
Update 20/03/2024 - 10h45:
We've detected a new DDoS attack starting at 10h30 today. Our team was quick to respond and we are actively mitigating this attack to minimize and avoid disruptions.
Update 19/03/2024 - 15h00:
After mitigating the attacks we witnessed this morning, traffic has subsided and we've not witnessed any further attempts for several hours. We will remain vigilant and will continue to monitor the situation for the next 24 hours.
Update 09h15:
The attack has been mitigated an new filtering rules are in place.
We continue to monitor the situation.
Dear customers, we are currently receiving a DDoS attack on our 109.68.161.0/24 ip range again. We are aware of this issue and are currently mitigating the attack by rerouting the traffic through our anti-DDoS provider. This attack is currently causing small disruptions in our services on this subnet, potentially leading to slowdowns or unavailability of certain resources. Our technical team is actively working to mitigate the impact of this attack and restore normal operations as quickly as possible. Thank you for your understanding and patience.